PDA

View Full Version : Charcoal troubles...


AWilliams
09-01-2019, 08:43 PM
Hey folks,
It seems lately I've been having trouble with my charcoal burning out and going cool too soon. I have a chimeny and usually use 50/50 lump and briggs. I'm using the Embers brand and RO lump. Seems like it gets screaming hot and then goes down to 250 pretty quick...??

BKING!
09-01-2019, 08:52 PM
Hey folks,
It seems lately I've been having trouble with my charcoal burning out and going cool too soon. I have a chimeny and usually use 50/50 lump and briggs. I'm using the Embers brand and RO lump. Seems like it gets screaming hot and then goes down to 250 pretty quick...??

Do you have your vents open? You might be smothering the coals

AWilliams
09-01-2019, 08:55 PM
yup...Weber kettle...top and bottom wide open

rwalters
09-01-2019, 09:19 PM
How are you lighting the charcoal? Chimney? How much charcoal are you using? 22 kettle?

Hoss
09-01-2019, 09:57 PM
I like lump.I light a few briquettes in a chimney,then dump those into the Kettle to get a base,then place lump on top.Lump does not burn well from top down in a Kettle for me.I also have to use more airflow with lump until it gets going.Once going,I close down the vents till desired temp.I also break down large pieces of lump or use the smaller pieces out of the bag on my Kettles.I am NOT a fan of large hunks of lump charcoal in a Kettle.I even break up the large chunks for use in my ceramic cooker.Works for me.Good luck!

SweetHeatBBQnSC
09-01-2019, 11:28 PM
There have been times I have had the same exact problem in my 22" kettle using a chimney starter.

pjtexas1
09-02-2019, 12:49 AM
I use RO lump in my Weber all the time. Never had that issue. I've used all kinds of briquettes but not embers. I'm sure you have dumped the ash, right?

Sent from my SM-G955U using Tapatalk