PDA

View Full Version : Problems with Maverick


Joe Black
09-03-2016, 12:52 PM
I have had a Maverick ET-732 for a little over 2 years with no problems. Just recently, my remote receiver has quit working. I put in new batteries, my remote is only 50' from rhe smoker, it just gives 260* for grate and 266* for meat. I try to change these readings, but it just keeps coming back to the same thing. The sending unit is right in line with my CC therms and the meat is fight with my Thermowand. It's either not sending correctly or the remote is not receiving correctly.

Has anyone had this problem or have any ideas for a fix?

TIA, Joe

kennyd0118
09-03-2016, 12:59 PM
Sounds like you may have lost link. Have you tried this? (from the manual)

Loss link alert
If the receiver is taken out of range or there is abnormal external interference or after shutting OFF
the transmitter, the receiver may not be able to receive the transmission from the transmitter. If
this happens over 4 minutes, the unit will alert you by beeping once for every 4 seconds to tell you
to re-sync the signal. Pressing any button on Receiver will stop the Loss Link beep.
To regain transmission signal, move the receiver close to the transmitter, turn OFF the Receiver
and then turn back ON. Press and hold the RESYNC button of the transmitter 2 seconds within
120 seconds and the temperatures should appear on the receiver display.
Remarks:
According to FCC Part 15.231(e) rule, the RESYNC button can be activated once every 12

pjtexas1
09-03-2016, 01:45 PM
Did you replace all the batteries in both units? If you swap the probes around does that make any difference? I'd also try pulling the batteries, wait a couple minutes and try again.

cats49er
09-03-2016, 04:01 PM
If all else fails contact the factory,good luck Joe.

JimmyR1Rider
09-03-2016, 05:20 PM
I'm extremely unhappy with my maverick. It doesnt even transmit 30ft. Always shows no probe connected errors. Have to do all sorts of shananagans to get it to read again. No bueno.

redchaserron
09-03-2016, 05:22 PM
If you're having problems with Maverick, you're going to have to call goose.

JimmyR1Rider
09-03-2016, 05:36 PM
I'd rather call my 9mm

Nuco59
09-03-2016, 08:47 PM
More and more, I'm glad I never dipped into the Game of Gizmos. Simpler may not always be better - but sometime it shines like a diamond.

txsmkmstr
09-04-2016, 11:08 AM
Maverick probes are prone to two types of malfunctions. The main thing is getting the probe wet - such as washing it. You don't want to submerge the probe past the point of mesh wire connection. It causes all sorts of issues reading temps.

Also, you'll need to clean the phono plug connection often - including the internal port. Best way I've found is to wipe the probe connection end, insert into x-mtter unit and twist back and forth several time. Repeat a time or two. If you're still not getting a reading the probe has likely failed.

I loved using the Maverick but as I got more acquainted with the nuances of my pit(s) I would stop using it.