PDA

View Full Version : Need some help with FEC


Yakfishingfool
05-10-2015, 08:27 AM
I went out and loaded the FEC 100 this morning and started her. About 3 minutes into the start I accidently hit the on off rocker, she turned off. She will not turn back on. Got a smoker full of meat, anybody got any suggestion on what may be the issue? Thinking fuse some where but not sure. THanks in advance for any suggestions. Firing up the BGE and webers to get meats going. SCott

Ron_L
05-10-2015, 09:53 AM
I may be too late, but there is a resettable breaker behind the control panel. I have a picture of where it is on mine somewhere around here. Let me look.

OK... Here is the picture of mine...

http://i35.photobucket.com/albums/d172/Ron_L/FEC-100/IMG_4603.jpg

LYU370
05-10-2015, 10:29 AM
Just an FYI, in Ron's picture, he has the side taken off and showing the back of the reset switch. The reset switch is on the front. Remove the four screws at the top that hold the controller in place, it will swing down. The reset switch is in the upper right corner on the hopper.

Yakfishingfool
05-10-2015, 10:45 AM
OK guys, so let me update you. I took out the four screws, lowered the door identified the button and pushed it. Nothing. I looked at the circuit boards and on one there is a green light when plugged in, but if I switch the unit to on it goes out. Still nothing. Anybody got any other ideas? Scott

Ron_L
05-10-2015, 11:13 AM
Sorry, Scott... I haven't seen that. You may want to search the Cookshack forums just in case.

http://forum.cookshack.com/eve/forums/a/frm/f/5501038883

Yakfishingfool
05-10-2015, 12:03 PM
THanks Ron, After talking to Andy and Phil and searching the boards I have to have had something fail. Not sure what the problem is but will call Cookshack tomorrow and see if we can trouble shoot it. Has to be a fuse somewhere I suspect or I fried something. Not sure what or where. Thanks for all the help though. Scott

LYU370
05-10-2015, 12:11 PM
I opened mine up, the only green light I see is on the power supply. Right next to the circuit board for the control panel. On mine it's off until I flip the master switch to on, then it turns on. When you hit the reset button, did you feel it click? Sorry I can't be more help. Give Cookshack a call tomorrow if you can't get it going today. They'll get you up and running again.

Yakfishingfool
05-10-2015, 12:57 PM
The green light is on when plugged in but goes out when the main switch is turned on. The green button has "no feeling" to it. Feels like and electric switch not a manual "click" as you push it. Makes me a bit suspect as well.

LYU370
05-10-2015, 01:20 PM
When I had to reset mine, there was a slight click you could feel, sounds like your switch isn't tripped. Must be something else. Let us know what Cookshack says.

Yakfishingfool
05-10-2015, 01:36 PM
will do!

Yakfishingfool
05-15-2015, 12:49 PM
FYI - the control board died and replacing the master switch. Thanks for the guidance I go there guys. FEC customer service was beyond excellent!!