PDA

View Full Version : Maverick ET-733 battery issue


AClarke44
10-13-2014, 11:49 AM
I know this has been discussed before but I wanted to post my experience to hopefully help someone. I purchased a Maverick ET-733 Wireless thermometer back in May. It didn't take long before I realized the receiver was eating batteries. I made sure to turn the unit off but every time I went to use it the batteries were dead. I started researching this forum and other places and realized this was a fairly common problem. I could and did remove the batteries after each use to make them last but after spending $70 for this unit I didn't think I should have to.
I decided to call Maverick today and ask what they will do about the issue. I was impressed by their response. Mostly impressed by the fact that they actually acknowledged the problem! That is rare theses days. Apparently quite a bit of their receivers had a defect that they are aware of. The simple fix, I send them the receiver portion only with a brief explanation of the problem and my name, address, etc and they will send a replacement receiver. Pretty simple to me.
If you have this problem they will fix it if you are still under the 1 year warranty. I bet even if you are outside the warranty they would fix the problem. If anyone needs their number its on the back of the instruction manual if you don't have that here you go 732-417-9666. That's their customer support number.

ButtBurner
10-13-2014, 11:54 AM
that's good

I had a bad probe once and they sent me a new one no questions asked. Did not even ask how old it was

I think they have good customer service

THoey1963
10-13-2014, 04:53 PM
Good to know. Thanks for sharing.