PDA

View Full Version : Yoder 640 owners...need your feedback


topchefvt52
06-06-2012, 08:46 AM
I pulled the trigger on a 640 in April. Discovered early on the LED temp was about 25 degrees lower than actual (verified with 2 digital probes) It was gobbling up pellets 3 lbs @ hr in the 250 F range. Turns out it shipped with the wrong 2nd fan. Yoder sent me a new one.

While the pellet usage dropped to 2 lbs/hr, the internal temps continued to run higher than the LED. I had several conversations with Joe and ended up running the smoker at 250 for 2.5 hrs. I had one probe on the upper shelf, one probe on the lower shelf and recorded LED/upper/lower temps every 15 minutes. Ended up with temps that all matched up within 10 degrees during the test. Mind you there was no meat in the smoker during the test.

Next day I set the LED for 250, load up 6 racks of loin backs and now the actuals are 25 degrees BELOW LED. Another call to Joe. He's baffled that I've gone from 25o over to 25o under LED. He sends me a new board and thermocoupler, which I installed yesterday. I fire up the Yoder at 350 to test the board & coupler...same thing...actuals are 25o lower than LED and this was verified with 2 probes set above and below the new thermocoupler.

Any ideas as to how to get the LED and probe to match up? I can live with the fact that my LED displays 25o less that the actual internal temp...if that remains consistant. Thing is, it's gone both way now and I'm reluctant to do an overnight smoke with butts or briskets.

Thoughts?

smknwhlswife
06-06-2012, 01:57 PM
PM my hubby - HoDeDo

He doesn't get on very much due to work, but if he sees it in his email he will answer you questions as best he can..

topchefvt52
06-06-2012, 02:21 PM
I emailed him at his S.O.W. email addy couple of weeks ago...nvr got a replay. Would love ot hear Andy's take on it.