PDA

View Full Version : maverick


tim hawk
11-29-2011, 08:17 AM
Keep going thru food probes quickly.They start reading way off on temps any suggestions.
thanks Tim

The_Kapn
11-29-2011, 08:25 AM
I have an ET 732 with the 2 origonal probes plus 2 of the long ones.
I put a bit of "heat shrink" tubing about 2 inches long at the place where the cable meets the probe.
Have had no problems whatsoever.

Did the same for my multitude of Taylor probes and stopped the failures totally.

TIM

kihrer
11-29-2011, 09:21 AM
I have an ET 732 with the 2 origonal probes plus 2 of the long ones.
I put a bit of "heat shrink" tubing about 2 inches long at the place where the cable meets the probe.
Have had no problems whatsoever.

Did the same for my multitude of Taylor probes and stopped the failures totally.

TIM

Sounds like a good tip. I have had problems with the probe that measures pit temp after it has been in for several hours. It will shoot up to 500 plus degrees or measure HHH. I think this happens when I start spraying my butts and briskets. My guess is that I am getting a short. Your tip should fix that problem. Thanks.

Ken

colonel00
11-29-2011, 09:24 AM
Never had any issues with my probes. To the OP, if you are going through them so quickly can you identify why? When you say they are reading way off on temps, how are you determining this?

Still Smokin
11-29-2011, 09:24 AM
My short cables had serious issues, so I ordered the longer cables as replacements, much better, but when I turn it on, the cooker probe is 10 degrees hotter than the food probe.

kihrer
11-29-2011, 10:51 AM
Are there any better probes for a Maverick other than the ones sold by the company?

pinkelephant
11-29-2011, 11:10 AM
I went thru several el cheapo wireless thermos (back when the "cheap" ones cost $40) until I got it thru my skull that the wire can't be near a flame. keep it high and avoid grill use. If your sticking them in a weber, your probably frying them. I haven't fried one in 5 years.

pinkelephant
11-29-2011, 11:12 AM
Are there any better probes for a Maverick other than the ones sold by the company?
they have the highest temp rating I've seen

tim hawk
11-29-2011, 11:36 AM
thanks for the tip i'll try heat shrink.using mine on uds plug the probe in now it reads 125 when its about 35.