Thread: iq110 problems
View Single Post
Old 12-02-2013, 08:28 AM   #1
Youngin'
On the road to being a farker
 
Join Date: 09-09-11
Location: Miami, FL
Default iq110 problems

I was wondering if someone could give me troubleshooting help with my iq110. I have 'tried' to use it 3 times and it never has gone passed 230*.

I fill up the ring on my WSM 18.5, haven't tried the 22.5 yet since I wanna master it with small cooks before big ones, and light a chimney up. Put the charcoals all over the unlit ones and build the WSM up. Close all the vents up, hook up my Maverick up and turn the 110 on to the desired temp. This is where the problems begin, the temp never makes it passed ~230* and takes about 2.5 hours to get there. On Thanksgiving I had to open up the vents in order to get it to ~245-250* (I had it set to 300*) and it slowly went up. Once I put the turkey on the temps dropped and the 110 started blinking red and eventually went in to solid red and didn't work again.

Am I doing something wrong? This is just about how the other 2 cooks went only difference was using ribs or a pork butt as compared to a turkey.
Youngin' is offline   Reply With Quote