The BBQ BRETHREN FORUMS.

The BBQ BRETHREN FORUMS. (http://www.bbq-brethren.com/forum/index.php)
-   Q-talk (http://www.bbq-brethren.com/forum/forumdisplay.php?f=5)
-   -   Head slap moment on 1st UDS cook... (http://www.bbq-brethren.com/forum/showthread.php?t=170008)

Brewin&Q'in 09-01-2013 12:54 AM

Head slap moment on 1st UDS cook...
 
Thought you all might find this funny...

So I'm a few hours into my new UDS' maiden voyage: four 6-8 lb pork butts. Starting out, I get the basket rockin', get up to temp and throw the butts on. After a little while, panic... Can't get the dang thing back up to temp! I open all the intakes, still sitting at 125. Take the lid completely off and fan it, not much movement. WTF? I wait, thinking maybe it'll be a gradual climb, but I can't seem to get above 150, no matter what I do! 45 minutes in, a big old stupid lightbulb goes off in my head. I take the lid off and look down. The side of one of the butts is sitting on the probe for the pit thermometer. Cue the wah wah wah trumpet noise.

It's cruising now, steady 240 and all is well, but I figured some of you seasoned vets would get a kick out of this noob mistake.

Cracking another beer and soaking in some pork smoke now, anticipating the feast to come tomorrow. Cheers, all.

mrbill 09-01-2013 01:03 AM

You're right, that is funny:)

AussieTitch 09-01-2013 01:05 AM

Funny but a common Mistake:redface:

rolfejr 09-01-2013 05:19 AM

I did that on a practice cook once and sat a butt on my Guru probe.
That little fan was trying to blow the top off the cooker!

HeSmellsLikeSmoke 09-01-2013 05:59 AM

At least it wasn't bees. :becky:

pbj 09-01-2013 07:07 AM

I was cooking wings a few weeks ago. The temp in my UDS would go from 275 to 200 then back up to 275 - repeatedly. I figured out the probe was being dripped on. Wings turned out great.

Ron_L 09-01-2013 07:34 AM

Quote:

Originally Posted by Brewin&Q'in (Post 2608997)
Thought you all might find this funny...

So I'm a few hours into my new UDS' maiden voyage: four 6-8 lb pork butts. Starting out, I get the basket rockin', get up to temp and throw the butts on. After a little while, panic... Can't get the dang thing back up to temp! I open all the intakes, still sitting at 125. Take the lid completely off and fan it, not much movement. WTF? I wait, thinking maybe it'll be a gradual climb, but I can't seem to get above 150, no matter what I do! 45 minutes in, a big old stupid lightbulb goes off in my head. I take the lid off and look down. The side of one of the butts is sitting on the probe for the pit thermometer. Cue the wah wah wah trumpet noise.

It's cruising now, steady 240 and all is well, but I figured some of you seasoned vets would get a kick out of this noob mistake.

Cracking another beer and soaking in some pork smoke now, anticipating the feast to come tomorrow. Cheers, all.

:doh:

:-D

I've done that with a big turkey in my Egg.

Fwismoker 09-01-2013 10:49 AM

Quote:

Originally Posted by pbj (Post 2609054)
I was cooking wings a few weeks ago. The temp in my UDS would go from 275 to 200 then back up to 275 - repeatedly. I figured out the probe was being dripped on. Wings turned out great.

Lol i need to keep that in mind because i clip my probe underneath the grate sometimes when i have a full load.


All times are GMT -5. The time now is 10:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
2003 -2012 BBQ-Brethren Inc. All rights reserved. All Content and Flaming Pig Logo are registered and protected under U.S and International Copyright and Trademarks. Content Within this Website Is Property of BBQ Brethren Inc. Reproduction or alteration is strictly prohibited.